2
Vote

Lizard TF fails if V9 TF dlls are present but not V8

description

Building a dotNet 3.5 version against TF version 9 dlls.
 
Original issue:
After using the Install package for .030 I looked for Start menu items to configure. i could not find them and I navigated to the install directory and executed the MonitorLizard.exe. The GUI comes up however when it tries to execute a TFS client call it raises an exception. I have TFS client installed, it is integrated into VS 2008 as well. All of the TFS dlls appear to be located in the PrivateAssemblies directory
 
 
 
 
************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.TeamFoundation.VersionControl.Client, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.TeamFoundation.VersionControl.Client, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
at Ltf.MonitorLizard.Lizard.btnTestAndSave_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

comments

somaritane wrote Nov 6, 2008 at 3:20 PM

I've faced with the same issue.
Fortunately, I've been able to find a workaround: "Drag" the missing dll into GAC and restart MonitorLizard.exe

wrote Nov 6, 2008 at 10:12 PM

wrote Nov 6, 2008 at 10:16 PM

Associated with changeset 16820.

karineguerin wrote Jan 5, 2009 at 12:38 PM

I have the same problem, fixed by installing Team Explorer 2008.
Now, I have the following error message : LoadLibrary "C:\Program Files\Lizard\LizardTF\CLizardShExt.dll" Fails.

I tried to uninstall and reinstall Lizard but the problem remains.

Visual Studio is not installed on the machine, since my purpose is to use a light TFS client.

Many Thnkas for your help.

wrote Jan 5, 2009 at 12:39 PM

wrote Feb 13, 2013 at 12:45 AM